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Contact 

Sage Software, Inc. 

271 17th Street NW 

Atlanta, GA 30363 

Phone: 470 - 447 - 4000 www.sage.com 

Visit our Web site at www.SageU.com or call (866) 888-6062 to learn about training classes that are 

added throughout the year.  

Copyright / Trademarks 

© 2019 The Sage Group plc or its licensors.  All rights reserved. Sage, Sage logos, and Sage 

product and service names mentioned herein are registered trademarks or trademarks of The 

Sage Group plc or its licensors.  All other trademarks are the property of their respective owners.  

SAP, SAP Crystal Reports, and SAP Crystal Dashboard Design are the trademarks or registered 

trademarks of SAP AG in Germany and in several other countries.  All other trademarks are the 

property of their respective owners. 

The Sage Software logo and the Sage Software product and service names mentioned herein are 

registered trademarks of Sage Software, Inc. or its affiliated entities.  SAP Crystal Reports is the 

registered trademark and technology of SAP AG, all rights reserved. NetLib is a registered 

trademark of Communication Horizons. Org Plus is a trademark of Human Concepts, LLC.  

TextBridge is a registered trademark of ScanSoft, Inc. Microsoft® SQL Server, is a trademark of 

Microsoft Corporation in the United States and/or other countries.  All other trademarks are the 

property of their respective holders.  

Notice / Disclaimer 

This document and the Sage HRMS software may be used only in accordance with the 

accompanying Sage HRMS End User License Agreement ("EULA").  You may not use, copy, 

modify, disburse or transfer the Sage HRMS software or this documentation except as expressly 

provided in the license agreement.  Nothing in this document supplements, modifies, or amends 

those terms and conditions. 

This material is provided for informational purposes only.  Accordingly, Sage does not provide 

advice per the information included.  The use of this material is not a substitute for the guidance 

of a lawyer, tax, or compliance professional.  When in doubt, please consult your lawyer, tax, or 

compliance professional for counsel.   

No license, express, implied, by estoppel or otherwise, to any intellectual property right is 

granted by this document.  Recipient is solely responsible for assessing the suitability of the 

information and assumes all risk of use.   

SAGE SOFTWARE, INC. HAS MADE EVERY EFFORT TO ENSURE THIS MANUAL IS CORRECT AND ACCURATE BUT 
RESERVES THE RIGHT TO MAKE CHANGES WITHOUT NOTICE AT ITS SOLE DISCRETION.  THIS COURSEWARE 
CONTAINS GRAPHICS OF THE ACTUAL SCREENS CONTAINED IN THE SOFTWARE.  ALL THE SCREENS WERE 
CAPTURED USING A VERSION OF SAMPLE DATA THAT WAS AVAILABLE AT THE TIME OF THIS PRINTING.  IF YOU 
ARE USING A DIFFERENT VERSION OF THE SOFTWARE, THE SAMPLE DATA ON THE SCREENS MAY DIFFER 
SLIGHTLY FROM THE PICTURES IN THIS TRAINING MANUAL.  

http://www.sage.com/
http://www.sageu.com/
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Sage HRMS Training Classes 

Sage HRMS Learning Series  

This learning session uses concepts contained in the following training classes on Sage 

University: 

HRMS - Sage HRMS - SAP Crystal Reports - Level 1: Laying the 
Foundation 

SAP® Crystal Reports for Sage HRMS connects you to data above and beyond the standard 

reports included with Sage HRMS by allowing you to create powerful, formatted reports with 

Sage HRMS as your centralized database and single point of truth. During this course we will 

train you to use SAP® Crystal Reports to extract the data you need from Sage HRMS and turn it 

into interactive, actionable information. Topics will include understanding the file structure of 

Sage HRMS, as well as using formulas and expressions. We will discuss creating and editing 

reports and using the Report Wizard. This training includes hands-on exercises so you can 

practice what you have learned in a demo environment. 

 

After you have completed this course, you will be able to: 

• Recognize the various files and fields of Sage HRMS in preparation for creating SAP Crystal 

Reports 

• Locate the Data Dictionary Reports in Sage HRMS 

• Use the functionality of the SAP Crystal Reports Start Page to quickly start SAP Crystal 

Reports Projects 

• Differentiate between the different Start Page portions and options 

• Navigate the interface to meet your report creation needs 

• Recognize SAP Crystal Report terms and definitions 

• Use the Report Wizard to build a report 

• Select a data source, table, fields, selection criteria, and template style using the Report 

Wizard 

• Properly print your report 

• Save your report 

• Create a report with group, summaries, totals and a graph 

• Make modifications to an existing report 

• Add report and column titles, adjust font sizes and field length, as well as a currency symbol 

• Create a report from scratch using the SAP Crystal Reports interface 

• Add data text box, boxes, shading, lines, drop shadows, and graphics to a report 
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Sage University  

To find training and register for training courses, visit  Sage University at www.sageu.com.  If 

you have Gold Support, you are entitled to 50% off Sage HRMS instructor-led training and Sage 

HRMS Any-time learning (ATLs) are free.  If you register for an instructor-led training class, 

use code HRMSResource to receive 10% off.  If you have Gold Support, this is in addition to the 

50% discount. 

To enroll in a course, go to https://sageu/hrms.and log on. If you do not have a log on, you will 

need to create one.  For registration assistance call Sage University Help Desk at 1-855-724-

3864 or email SageUniversity@sage.com. 

 

Session Objective 

In this session the instructor will: 

• Create an SAP Crystal Report using the Report Wizard 

• Discuss report terminology and report sections 

• Modify the report 

 

Icons 

 

This is a note 

 

https://sageu.csod.com/client/sageu/default.aspx?_ga=2.238070021.408657000.1536069181-1115622968.1476311271
https://sageu/hrms.
https://sageu.com/en-us/home.html
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SAP Crystal Reports Terminology 

Report Wizard 

The Report Wizard is an excellent tool for new users. The Report Wizard will walk you through 

report creation in a step by step process, allowing you to quickly create reports.  

Data Source 

The data location from which SAP Crystal Reports is currently reporting and the method used by 

SAP Crystal Reports to connect to said data. For the purposes of this webinar, the Data Source 

will always be Sage HRMS data, using the Abra HRMS Data Access connection method. 

Text Object 

A text object can contain text, multiple data fields, calculations, or any combination thereof. 

Design Tab 

The Design tab is where the SAP Crystal Report is built and contains all of the 

information for your report. For this purpose, the Design tab is separated into sections and 

contains guidelines to facilitate SAP Crystal Report creation. 

 

When building your SAP Crystal Report from the Design tab, you will only be viewing the field 

name for data you wish to view. The report will not populate with data until you use the Refresh 

button to actually pull the data from Sage HRMS. This allows you to build your report from the 

ground up without taxing Sage HRMS or your network resources by constantly bringing in data 

during report creation. 

Preview Tab 

The Preview tab gives you the ability to view the SAP Crystal Report as it will appear when 

printed, run, or exported. 

 

 

Similar to the Design tab, you can also make adjustments and additions to your SAP 
Crystal Report directly from the Preview tab. This allows you to make adjustments 
and see how they will appear as a finished product. 

Grids and Guidelines 

When working in either the Design or Preview tab, you have the ability to use guidelines and 

grids to ensure the precise placement of your fields. Guidelines are located in the rulers, and 

appear as arrows. They are located both vertically and horizontally, and allow you to “snap” your 

fields to the guideline to ensure proper alignment. 
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When a field is properly “snapped” to the guidelines, you will see indicators appearing as red 

marks where the field is set. 

 

 

To delete a guideline, click the guideline with the left mouse button and, while 
holding down the mouse button, “drag” the guideline to a location outside of the 
ruler. The guideline will disappear. 

 

Grids place a matrix of dots across your SAP Crystal Report and, much like guidelines, allows 

you to ensure proper placement. However, gridlines do not have “snap to” functionality, and are 

used as navigational markers to ensure alignment. In the screenshot below, we have manually 

aligned our fields using gridlines. 

 

 

 

 

Grids are turned off by default in SAP Crystal Reports. To enable the gridline 
feature, navigate to View > Grid and select where you wish to use them (Design 
and/or Preview.) In addition, you can also opt to adjust the grid size from here as 
well. 

 

Toolbar Icons 

The following icons will be used when modifying a report:   

 

Print Preview – Displays how your SAP Crystal Report will appear when printed 

 
Refresh (F5) – Used to “run” the SAP Crystal Report, populating the report with data 

 

Undo – Standard Microsoft Office Undo functionality 

 

Record Sort Expert – Allows you to sort the records on your report 

 

Select Expert – This icon allows you to create criteria for which records are returned 
when running your SAP Crystal Report 
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Report Sections 

The different SAP Crystal Report sections define where the data will appear on the SAP Crystal 

Report, and the manner in which it appears.  

Report Header – The report header displays information that will appear once, at the top of the 

report on the first page of the report only.  

Page Header – The page header displays information that will appear at the top of each page of 

the report.  For example, if the report is one hundred pages, the page header will display at the 

top of each of the one hundred pages. 

Details – The details area contains the body of the report and will display all records that have 

been returned.  There will be a separate Detail line for each record.  In addition, any objects 

placed in this section will appear with each new record. 

Report Footer – The report footer displays information that is to appear once, at the end of the 

report.  This section is usually used for grand totals. 

Page Footer – The page footer will display at the bottom of every page of the report. As 

per the example above, if your SAP Crystal Report was one hundred pages long, any items in the 

page footer would appear at the bottom of all one hundred pages. 

If your report contains Groups, you will see the following two sections: 

Group Header – The group header will appear once, at the beginning of the group. 

Group Footer – The group footer will appear once, at the end of the group.  

 

 

If your SAP Crystal Report does not contain any groups, the group header and 
group footer will not be present.  If your report contains multiple groups, you will 
have multiple group headers and group footers; one for each group. 
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Links and contact information 

Topic URL Additional Information 

Sage City – HRMS 

Forum 

https://www.sagecity.com/support_

communities/sage_hrms/f  

Ask product questions 

Share tips and tricks with Sage 

peers, partners, and pros 

Questions and 

Answers relating to 

Sage HRMS 

Learning Series 

https://www.sagecity.com/support_

communities/sage_hrms/f/sage-

hrms---training  

This link will take you directly to 

the Sage HRMS – Training forum 

on Sage City 

Sage University https://www.sageu.com/hrms  
Log on 

Training and certification 

View training by subject 

Create a Profile 

Test your knowledge 

View training schedule 

Sage University 

Help Desk 

 Telephone: 1-855-724-3864 

Email: 

SageUniversity@sage.com 

Discount code 

when registering 

for Sage HRMS 

instructor-led 

training 

HRMSresource 10% off 

Register or access 

on demand 

recording for Sage 

HRMS Learning 

Series 

https://get.sage.com/HRMSLearnin

gSeries  

 

Grad Cap icon in 

Sage HRMS 
 

A link to Sage University to 

browse for training on the related 

area in Sage HRMS 

 

 

https://www.sagecity.com/support_communities/sage_hrms/f
https://www.sagecity.com/support_communities/sage_hrms/f
https://www.sagecity.com/support_communities/sage_hrms/f
https://www.sagecity.com/support_communities/sage_hrms/f
https://www.sagecity.com/support_communities/sage_hrms/f/sage-hrms---training
https://www.sagecity.com/support_communities/sage_hrms/f/sage-hrms---training
https://www.sagecity.com/support_communities/sage_hrms/f/sage-hrms---training
https://www.sagecity.com/support_communities/sage_hrms/f/sage-hrms---training
https://www.sagecity.com/support_communities/sage_hrms/f/sage-hrms---training
https://www.sagecity.com/support_communities/sage_hrms/f/sage-hrms---training
https://www.sagecity.com/support_communities/sage_hrms/f/sage-hrms---training
https://www.sageu.com/hrms
https://www.sageu.com/hrms
https://get.sage.com/HRMSLearningSeries
https://get.sage.com/HRMSLearningSeries
https://get.sage.com/HRMSLearningSeries

